Toad World® Forums

TOAD Menu Bug when Connection Lost

There is a bug in TOAD for Oracle in which the menu is messed up after a connection is lost by external means such as a session timeout or network disconnect. Whenever such an event occurs, the menu appears to be the same, but clicking menu items does nothing. Hovering across the menu bar shows that the men items have been reduced to single letters. As shown in this screenshot:


The menu is restored after minimizing and maximizing the window.


Hi Russ,

I just tried to reproduce this in 14.0 and for me that does not happen.

Here's what I did:

  1. Launch 14.0, and make a connection (editor auto-opened)
  2. Use SQL*Plus to kill my Toad session
  3. Use the main menu to try to open a schema browser
  4. expected "not connected" error is shown. Just close it w/o reconnecting
  5. Try something on main menu again, hover over it.

If you can reproduce it with different steps, please correct my steps.


Here is what I do to reproduce the problem:

  1. Open a new session.
  2. Run a query (F9) in the editor.
  3. Kill my TOAD session with SQL*Plus.
  4. Without selecting anything in the menu, try to run the same query in the editor. Gets connection error.
  5. Move the mouse up to the menu bar.

It does not occur every time, but every second to fourth time the menu is sad.


I've tried several times and still no dice, but in the next version, instead of the just the "not connected" message below, you'll get a reconnect prompt so you don't have to access the main menu at all at that point.

If you want the reconnect prompt now, go to Options -> Editor -> Behavior, and check "Display SQL errors in popup dialog". Note - that will make all errors after F9 show in a popup, which was unpopular with some people after we changed the dialog. In 14.1, "connection lost" type errors always popup, regardless of this setting, to make reconnect more convenient.

Fair enough. Some of my sessions are subject to quick timeouts, and this problem occurs often to me. Just did again as a matter of fact.

14.1 will have several improvements to deal with lost connections.

If you want to see what they will be, go here, do a CTRL+F and type in "lost".