Toad World® Forums

Unable to connect using Toad for DB2


#1

I installed Toad for DB2 5.6 (32-bit)

When I try to connect to a DB2 database, I get the following error:

ERROR [42724] [IBM] SQL1109N The specified DLL “GSKit Error: 202” could not be loaded. SQLSTATE=42724

Can I get some help on this please?

The only DB2 install I had prior to Toad was the Db2 Express-C install which I believe is all I need for having DB2 client files.

I also updated my system path to include the following folders from my DB2 install:

C:\Program Files (x86)\IBM\gsk8\lib

C:\Program Files (x86)\IBM\SQLLIB\BIN

What am I missing?


#2

Hi,

See this post in Toad World - www.toadworld.com/…/20303.aspx

The first directory listed in your post seems a little unusual. Have you verified that gsk8sys.dll or gsk8sys_64.dll exist in these directories?

Regards,

Adam


#3

Hello, thanks for replying!

The directory is because I am on a Windows 64-bit box. But I installed a 32-bit client for DB2 and the 32-bit version of Toad to try and avoid the problem like that guy had in the post you linked.

I did initially try with 64-bit version of Toad with 64-bit ver of DB2, but I got the same error. It did not let me install a 32-bit ver of DB2 while I still had the 64-bit installed, so I uninstalled DB2 and reinstalled with the 32-bit one while keeping toad 64-bit. Still did not work. Now I am using both 32-bit and still it does not work.

And yes, under that folder I have all the gsk8 DLLs, including gsk8sys.dll


#4

Just so you know, Toad for DB2 installs its own DB2 client, and you do not need a separate DB2 client for Toad to connect. The only difference between the 32 and 64 bit Toads are the DB2 client it installs. You must install the version of Toad that matches an existing client because a 32 and 64 bit version of the IBM DB2 client cannot be installed on the same machine.

It worries me that you said you reinstalled a 32 bit DB2 while keeping Toad 64-bit. That should not have been possible.

Can you try to uninstall all the Toads and DB2 clients, install Toad with 32 bit client, and check to make sure you have the 32 bit gsk directory in your system path environment variable?


#5

So the separate DB2 install that I am doing (The Db2 Express-C) is just for getting those gsk8 DLLs ? It appears the db2 client that comes with Toad for Db2 does not have those libraries…

The last thing you mention I should do is exactly what I just did last - I uninstalled Toad & the Db2 Express. Reinstalled both using Win-32 versions, and updated the environment system path on my machine to include the path to the gsk8\lib folder.

Is there perhaps a folder within the Toad install I could just copy + paste these gsk8 lib files to rule out any issue with Toad finding them?


#6

P.S. I did a test to confirm the path variable was set correctly. I opened a command line window (cmd) and without changing directory I just typed gsk8ver and hit enter (I put both the \lib and \bin folders from the gsk8 library to the path) and I got a whole bunch of output on the gsk8 library files. So I don’t understand why Toad is failing to find them…


#7

Your are correct; the Toad client does not include the GSKit libraries.

Will you please try to connect to your database using the DB2 Express-C CLP, and the Toad installed client’s CLP?


#8

OK, I am quite new to using DB2, so I assume you want me to run the db2.exe command line tool? When I run it under the DB2 SQLLIB folder, I get this error:

SQL10007N Message “-1390” could not be retrieved. Reason code: “6”.

Running it from TOAD’s SQLLIB folder, I get a different error:

DB21061E Command line environment not initialized.


#9

For Toad CLP: Go to the start button->All programs->IBM DB2 Toad 5.6->Command Line processor

For IBM Client CLP: Start button->All programs->IBM DB2 {your client name}->Command Line processor


#10

When I try Toad CLP - I see the same error printed in the console window as shown in the GUI - regarding The specified DLL “GSKit Error: 202” could not be loaded.

When I try the IBM Client CLP nothing happens when I run Command Line processor. It is probably encountering some error but not displaying the console window.

I can however run Command Line Processor Plus, and connect to the desired database and run a select query


#11

The IBM client failing to start indicates a corrupted client, and I can’t explain why CLP+ can connect. Unless you were connecting to a different database.

Since Toad doesn’t need the IBM client let’s focus on the Toad client. The “GSKit Error: 202” could be a problem finding your SSL key and stash files.

In the Toad CLP type “get dbm cfg”. Check the SSL_CLNT_KEYDB and SSL_CLNT_STASH parameters, and make sure they’re set to the correct paths.