Toad World® Forums

Unable to log into database after moving from 8.5 to 10.5.


#1

Hello,

After updating to 10.5, I receive the error “ORA-01004: default username feature not supported; logon denied.”

I’ve looked into the issue, and it appears that this is related to using windows credentials to log into the database. The database was never set up this way, so I’ve been trying to specify the correct username and password. I’ve tried changing SQLNET.AUTHENTICATION_SERVICES in sqlnet.ora on both the client and server ends, with no effect. I’ve also tried installing Toad on different computers, again seeing the same error message. No other applications are affected, just Toad.

Is there something different about how Toad handles logins in 10.5? Or is a default setting changed from 8.5? I installed 8.5 originally, and didn’t have to add any special settings, other than specifying the database.

Thanks so much guys!

John


#2

Nothing that I can think of.

This might be a stupid question – but you are supplying a username and
password in Toad’s login screen, right?


#3

Upgrading from 8.5 to 10.5 will require you to re-enter your logon info, esp the
passwords


#4

I have the username and password, it’s entered on the login screen. User / Schema is the username section right? And password is self explanatory. Believe me, I’d love to have it be something easy like I entered the information in the wrong spot.

Is there any setting I have to select to force it to send the credentials I provided?


#5

Have you tried creating a new connection from scratch instead of using anything
from the historical/left-hand-side of the screen?


#6

#7

I make new connections each time. Since it doesn’t connect it won’t save the connection, and it didn’t bring any of 8.5’s settings to 10.5.

I don’t know if this will help, but when I leave the login fields blank I still get ORA-01004. However, if I put in bad login information, I get ORA-01017: invalid username / password. So it’s doing something with the login info I give it. I’m going to look into the possibility that there was some kind of DB change that coincided with the Toad upgrade, but it doesn’t seem likely.


#8

I’m using the same Oracle Home, and I can connect with other products. I am not connecting by proxy. This is true for the other computers I’ve installed it on as well.


#9

A screenshot of the Toad login window and the error message might help clear up
things a bit…


#10

Please attach a support bundle (help->support) so that we can better see into
your issue


#11

I’m afraid I’m out of ideas then. I suggest opening a case
with Quest support. They may have heard of this before.


#12

#13

#14

Going to try and hit all the responses. I do not have another username / password to access the database with. I’ve sent the DBA’s an email asking for their input on the issue.

Here is a screenshot of the error and login screen: http://i.imgur.com/LF1Mt.png

And here is the support bundle:


#15

The error message you show means that the database does not have the option OPS$
set to support logins without username/password – this is not toad

I will look over the support bundle now …


#16

EXTERNAL – that’s OS Authentication….isn’t it?


#17

EXTERNAL – that’s OS Authentication….isn’t it?


#18

Issue solved everyone: The DBAs got back to me, they said to put the username in quotes. It worked. I won’t claim to understand why there are quotes in the username now, but it worked.


#19

Sounds like you are on 11g and using case sensitive usernames. Maybe
8.5 automatically wrapped quotes around the username and 10.5 does not.

Ed
[TeamT]

On 5/13/2010 12:09 PM, johnam2 wrote:

Issue solved everyone: The DBAs got back to me, they said to put the username in quotes. It worked. I won’t claim to understand why there are quotes in the username now, but it worked.


#20

Hi Ed,

Sounds like you are on 11g and using case sensitive usernames. Maybe
8.5 automatically wrapped quotes around the username and
10.5 does not.

I suspect it’s possibly maybe perhaps because “external” is a reserved
word?

Cheers,
Norm. [TeamT]

Information in this message may be confidential and may be legally privileged. If you have received this message by mistake, please notify the sender immediately, delete it and do not copy it to anyone else. We have checked this email and its attachments for viruses. But you should still check any attachment before opening it. We may have to make this message and any reply to it public if asked to under the Freedom of Information Act, Data Protection Act or for litigation. Email messages and attachments sent to or from any Environment Agency address may also be accessed by someone other than the sender or recipient, for business purposes. If we have sent you information and you wish to use it please read our terms and conditions which you can get by calling us on 08708 506 506. Find out more about the Environment Agency at www.environment-agency.gov.uk

Information in this message may be confidential and may be legally privileged. If you have received this message by mistake, please notify the sender immediately, delete it and do not copy it to anyone else.

We have checked this email and its attachments for viruses. But you should still check any attachment before opening it.
We may have to make this message and any reply to it public if asked to under the Freedom of Information Act, Data Protection Act or for litigation. Email messages and attachments sent to or from any Environment Agency address may also be accessed by someone other than the sender or recipient, for business purposes.

If we have sent you information and you wish to use it please read our terms and conditions which you can get by calling us on 08708 506 506. Find out more about the Environment Agency at www.environment-agency.gov.uk