Toad World® Forums

Using Filters on Windows 10


#1

I am using Toad for Oracle 13.0.0.80. I recently moved to Windows 10 on my laptop and I noticed that filtering is not working (it did on Windows 7). Do I need to change any settings so that this works?


#2

Which filtering?

Bogus text here to hit Toad World’s 20-char requirement :slight_smile:


#3

User filtering. I have one set up so that I don’t have to scroll through the whole list. We have issues with one specific system user account.


#4

Can you be more specific about the problem? Where exactly in Toad you are, what you’re trying to achieve and what’s happening instead?


#5

I am in the schema browser, on the Users tab. Using the search text box, I filter the list so that only the user account I am interested in is in the list. I then click on the drop-down next to the filter icon and select the option “Save Current Filter As…”. I then give the filter a name and select the option to Save filter data for users only and click OK. When I go back to the drop-down for the filter, I can see the new filter name, but when I select it nothing happens. The Users list is not filtered.


#6

The dropdown next to the filter icon does not save what you type in the edit box above.

If you click the filter icon and set filter info there, those settings in that dialog is what is saved.

If you want to recover a previously used text in that edit box, just right-click it.


#7

OK, well the method you described certainly works. If clicking on the drop-down next to the filter icon and selecting Save Current Filter As… doesn’t work as I described, then how is that option intended to be used? I can tell you that the method you described is not how I’ve saved this filter in the past. This is why I thought that moving to Windows 10 might have been the difference.


#8

Like this:

  1. click the filter icon to set up your filter in the “Schema Browser Filters” dialog.
  2. click the drop-down arrow next to the filter and use “Save current filter as” to give it a name. This will save whatever you did in the dialog, but not what is in the filter edit box on the schema browser itself.
  3. some time later, when filter is no longer set, click the dropdown arrow to restore a saved filter from step 2.

#9

Thanks for your help on this. It’s now set up as needed.