Why is whitespace shown with black background?

Using beta 16.2.77. In the editor window, whitespace is shown with black background. How can I unset that feature?


I wonder if that is some remnant of trying out dark mode.

Go to Options -> Editor -> Font and Styling. If you just want to reset all editor styling to default then click "Restore defaults".

And I was going to add.....if you have other customizations that you don't want to lose, you can go to "Whitespace" on the left and then change the foreground color for it.....but I see that causes an error, so I'll fix that.

After installing each beta drop, I always copy user settings from 16.1, which is not in dark mode and is not exhibiting this behavior.

Selecting "Restore Defaults" has not resolved the issue. These images are after Restoring Defaults. I have bounced Toad, which has had no effect.


Hm, I think it is not related to dark mode after all. Most likely due to edit control changes. I can't reproduce this, but Let's wait to see what @mstaszew says. Weird that a reset didn't fix it.

I have had dark mode enabled at some time in the past, perhaps during the 16.1 beta cycle.

Restore Defaults should have reset everything, but if you want to double-check, then

  1. close Toad
  2. go to user files folder
  3. delete EditorLexers.XML and EditorLexersDark.XML (if present)

That will guarantee that you are on default colorization. I don't know if that will fix the problem though.

It seems to be related to Options -> Editor -> Display -> Show whitespace.

If you uncheck that option, this problem will go away.

I'll log it for Michael to fix.

Deleted EditorLexers.XML ((EditorLexersDark.XML not present). This did not fix it.
Disabling Show Whitespace removed the black, but also isn't showing whitespace. :slight_smile:

Thanks John for your help.

@DougK - Thanks, this will be fixed in the next beta.