Toad World® Forums

Toad Editor behaviour copy paste ctrl chars

:smiley: :smiley: :smiley: :smiley:

Norm. [TeamT]

Thanks for the update John.
I am having to move to SQL Developer for now :frowning: the bug is causing me to make to many mistakes.
Hope you can find a work-around/fix soon.

If you are allowed to re-install the Citrix Workspace app, and can do so with the "App Protection" option disabled, Toad will stop doing that.

I will contact the department who install software and ask if they can re-install without app-protection but I guess its switched on for a security reason.
I am in Denmark so they time difference is an issue for us too.
I'll write again when I hear something.

I have now got Citrix Workspace removed and Toad is happy again :slight_smile: ....and so am I.
I look forward to the bug fix in the future but for now thanks for the help John.


1 Like

Great. We have a lot of eyes on this. It's been tough to figure out exactly why this is happening but I believe we are getting close. We'll let you know when it's solved.

We believe that this is actually a bug in Citrix Workspace App, not Toad. ​ You don't have to be actively using Citrix Workspace App. It only needs to be installed to cause problems for Toad. This began after the July 2020 update to Citrix Workspace App.

The App Protection option of Citrix Workspace app seems to have a keyboard hook and is incorrectly processing the HC_NOREMOVE code. ​

Toad is not the only application to experience problems when Citrix Workspace App is installed with the App Protection Option. For example, in Excel, if I am editing a cell, CTRL+A does nothing. It should select the entire cell contents (and does when Citrix is not installed). Toad's problem is more severe, but this illustrates that Citrix Workspace App is causing problems for other apps.

I have opened a support case with Citrix. I'll update here what they say.

Solution for Toad 14.0 or newer

  • Edit Toad.ini (click here if you need help finding it).
  • Add CitrixWorkspaceAppWorkaround=1 under [SETTINGS]

Solution for Toad 13.3 and older

  • If you don't need Citrix Workspace App, uninstall it.
  • If you need Citrix Workspace App, uninstall it and reinstall with the "App Protection" option unchecked.

Update 2/10/2021: There is a new version of Citrix Workspace App, version 2102, that resolves the problem. You can get it here: Citrix Workspace app 2102 for Windows - Citrix

1 Like

Well, I was researching this issue and came across this thread. @JohnDorlon I have to admit that I knew what 'philately' was. I know because I was a philatelist, and also @NormTeamT probably told me this joke MANY moons ago.


Long time no see. How's California? It was on fire when I visited last year.

I might have told you the joke, back in ADC, many years ago - but, you know, recycling!

Take care, stay safe.



Do you know the location of Toad.ini in windows 10?

Generally, it's under C:\Users\YOUR_WINDOWS_USER_NAME\AppData\Roaming\Quest Software\Toad for Oracle\TOAD_VERSION\User Files.

Be sure that Toad is not running when you make edits to Toad.ini or any file in the User Files folder.

You can be sure to find the right one this way:

  1. In Toad, Go to Options > General.
  2. Under “Application data directory” section click on “Open folder”
  3. Keep this folder open in Windows Explorer and close Toad.
  4. In Windows Explorer, go into the User Files folder. Toad.ini is in there.
  5. You can double-click Toad.ini to edit with Notepad. Save it before opening Toad again.

I added that to my TOAD.INI file and it did not work.

My toad for oracle base 64bit version is Should I run a different version?

As I mentioned above, the ini setting works for Toad 14.0 and newer.

To solve the problem for Toad 13.3, you need to either uninstall Citrix Workspace App, or disable their App Protection Option (the only way to do this is to install and reinstall Citrix Workspace App, and not check the option during reinstall).

I have a support case open with Citrix, but I believe that the problem is on their end. What we are doing in Toad 14.0 is just a workaround.

(I edited my post above so that it is more clear)

Toad for Oracle 14 is still in beta right? I cannot find a place to download it

Yes, it is still in beta. You can get it here

1 Like

I will first uninstall citrix workspace app if my IT department lets me :slight_smile:. If they don't I will try the beta version. Thanks!

1 Like

Hi John and Team,

I am using toad 12.9 version. as that is the latest available to use in my company estore.
I have uninstalled Citrix Workspace App. Still I have issue the issue with the toad.
Could you please suggest.

Thanks in advance,

Update to latest Citrix workspace app. They fixed it a few weeks ago

Edit: You uninstalled Citrix word space app completely? And restarted after? And verified that is is gone? If so then maybe some other software is interfering? Not sure

Citrix is completely removed but still have the issue. I have raised an ServiceRequest Number:4845639. Could you please connect and help.

Hopefully Quest Support can help you figure out what's going on. If not, they'll contact me.