Automation Designer incorrectly considers connection as read-only

I have an Automation Designer app which (simplified) looks like this:

  • action 1 uses a read-only connection to export data to XLSX
  • action 2 uses a writable connection to import that data in a different database

This worked fine in 16.0 with an client, until I upgraded to 16.2 and at the same time added a client.

When I now run the entire app, it fails on the 2nd action with "Import (Import Table Data) failure: Target schema is read only."

However, when I select that 2nd action and choose "Run", it works fine!

I tried to recreate the connection, change it to something else and back again: no success.

Workaround: When I changed the connection from the 1st action to a writable connection (even though I'm only reading), the whole app now works fine again!

So, my problem is solved, but it seems like there's an issue with Automation Designer somehow remembering the read-only flag from the 1st action when it starts with the 2nd one.

Hi Pieter,

I'll take a look at this soon, but if you don't need that XLSX file for anything other than export from one DB and import into another, you might want to try the "Copy Table Data" action instead. I don't know if it will have a similar error, but assuming it doesn't, and your Export is just a simple "select * from table", then Copy Table Data should be faster overall.


Thx for the suggestion! However, that's not an option since there's some SQL processing involved, and I also want to include the XLSX in a later e-mail. As I mentioned : I have a workaround, no need to jump on this; I just wanted to let you know :wink:.

I'm glad you can work around it. I've logged it in our bug tracking system so I don't forget.

Thanks for reporting it