Toad World® Forums

Can I download Toad for Oracle Freeware 11.6 from www.toadworld.com, and does Toad for Oracle Freeware 12.8 supports Oracle 8i?

Dear Sir,

Could I download Toad for Oracle Freeware 11.6, which is an older version, from www.toadworld.com? and how?

It is because I need to access Oracle 8i.

And does Toad for Oracle Freeware 12.8 supports Oracle 8i?

Grateful for your help.

Thank you.

Morning Chowaion,

the reason you cannot connect to an early Oracle version si not a Toad

problem, but an Oracle Client problem. Starting around 9i (I think) the

Oracle client had checks built in to make sure that you didn’t try to

connect to an older version of the database.

If you have an 8i (or 9i) client, you’ll be able to connect down to

Oracle 7.3. I used to do this when I was running an 11g client but still

had to connect with 7.3.4, 8.0 and 8i databases. I installed the 8i

client and for the databases that I needed to use it with, I chose it as

the Oracle Home to use on the connections screen.

The only problem with this was the fact that Toad can only use one

Oracle Home at a time, so if I connected to an old database, I had to

use the same Oracle client to talk to newer versions, and sometimes they

refused the connection - because there’s a check in the database to see

that the client in use isn’t too old!

Oracle want everyone to be running the latest versions.

HTH

Cheers,

Norm. [TeamT]

Dear Norm.

Thanks a lot for your useful answer.

My situation is that I have the 8i client installed on my desktop and I only need to access the Oracle 8i database (because it is the database of an old system).

With my situation described above and according to your answer, am I correct that I can use the Toad for Oracle Freeware 12.8 (the latest version) to access the Oracle 8i database through the 8i client installed on my desktop?

Thank you again.

Chow Wai On

Hi Chow Wai On,

as long as Toad for Oracle Freeware allows you to choose the desired

Oracle client from the new session dialogue, then you should indeed be

able to use an 8i client.

I can’t confirm though, as I don’t use the Freeware version of Toad for

Oracle.

Maybe one of the developers will help out further when they come online

later.

You could just try it though, I’m pretty certain it will work.

Cheers,

Norm. [TeamT]