Toad World® Forums

can not access main toad window


#1

I have 10.5 version … recently installed on a re-imaged laptop. Has been working great for couple of weeks. This morning, when I launch Toad, I only see the connection window. After entering connection information, when I click on connect, toad windows disappear. I see Toad running in tast bar, but can not resize/maximize its windows so that it comes up in front of me … Any ideas?


#2

One monitor or two? My first thought is that the main window may be positioned
where it was on a second monitor when it was closed. . .


#3

As suggested (more or less) Toad could be on the screen. Be sure it is the
active program. Hit Alt-Space, M meaningMove, use one of the cursor keys and
then the mouse and the screen will probably appear.

btw, 10.5 is not the latest version.

Groetjes,
Wim

On Mon, Feb 21, 2011 at 21:54, Phyllis Helton wrote:

One monitor or two?  My first thought is that the main window may be
positioned where it was on a second monitor when it was closed. . .

#4

Morning “justoracledba”,

… information, when I click on connect, toad windows disappear. I see Toad
running in tast bar, but can not resize/maximize its windows so that it
comes up in front of me … Any ideas?
Possibly!

Right click on the Toad button in the task bar - what options are
enabled? If you see Restore and Minimise, then Toad is currently
maximised - possibly as Phyllis mentions, off screen. Click Restore.

Assuming Toad is still AWOL, right click again on the task bar button
and you should see Move, Size, Minimise and Maximise enabled this time.
Click move.

Using the arrow keys (or, if the mouse cursor has vanished off screen as
well, the mouse) attempt to move the Toad main window back on screen.
When you get there, press ENTER to lock it down.

HTH


Cheers,
Norm. [TeamT]


#5

Thanks everyone for their responses.

This method worked: “Hit Alt-Space, M meaningMove, use one of the cursor keys and then the mouse and the screen will probably appear”

Toad main window had gone up (out of the screen) and vanished. I was able to bring it “down” and into my screen again and locked in. All new invocations of the program now starts at that location, which is great.

thanks again.


#6

Something else you might look at if this happens in the future.

Find the Toad.ini file located in the following directory on my system:

Documents and Settings\User Name\Application Data\Quest Software\Toad for Oracle\10.6\User Files\

You will want to scroll about 80% of the way down through the form until you find a section as follows:

[MAINFORM]
TOP=214
LEFT=254
WIDTH=962
HEIGHT=911
DockLayout=

Your system probably had a negative number for the top. If you changed this to a positive number you would also solve your problem.

Your problem was similar to the one I was having last week with the Filter so I went and looked to see if I could find a similar solution to yours in the Toad.ini file.

Andy


#7

We had some code in place to prevent placing the main form off screen in the
positive direction, but we didn’t check negative. This will be fixed in
the next version.

-John


#8

I had a similar problem direction wise. I connected a second monitor to my laptop, did everything right (setting wise and then tried to move the cursor left to my second monitor. Nothing happened. So I laboriously undid all my settings.

Then I mentioned this to someone and he said (wait for it) … “did you try moving the cursor to the right” … Duhhhh of course I had forgotten the other direction. Back to the drawing board. Changed the settings and of course it worked.

ETRG (Erwin The Retired Guy)