Toad World® Forums

Cannot create a new DBMS_SCHEDULER Program

Afternoon All,

  • Toad 12.1.0.22 64 bit
  • Oracle 11.2.0.4 64 bit
  • Windows 2008 and 2012 in the cloud. 64 bit.
    I’m trying to use database->Create->Scheduler Program to create a new scheduler program, to be run from a job.

I want the program to run a script on the server, so I choose “executable” on the Basic Info tab. This disables the Program Action button, so I cannot specify a script name to be run, but clicking OK does create the program. I can also enable or disable it in the schema browser.

This problem affects PL/SQL_Block type programs also, only STORED_PROCEDURE allows me to select anything to be run as the program.

The SQL generated is as follows:

BEGIN
SYS.DBMS_SCHEDULER.CREATE_PROGRAM
(
program_name => ‘FCS.XXND_TEST_PROGRAM’
,program_type => ‘EXECUTABLE’
,program_action => ‘’
,number_of_arguments => 0
,enabled => FALSE
,comments => ‘This program will be called from a job. It is a test of the scheduler in calling external batch scripts.’
);
END;
/

At the moment I’m having to copy the SQL to the editor and add in the required script name before I execute the code to create the program.

Hi Norm,

The “Program Action” button selects a stored procedure/package, so that’s why it’s only enabled for STORED_PROCEDURE. For executables, you should be table to just type the file name in the program action box, without the aid of the lookup button. Newer versions of Toad will give you a “lookup file on server” dialog.

-John

Duh! Silly me.

I was looking at the screen and didn’t realise that the huge white area under the button was where I could type stuff into.

Thanks a lot John.

Cheers,

Norm. [TeamFeelingRatherSilly] :wink: