Toad World® Forums

Code Assist Window


#1

I’ve been lurking on this board for a long time. By listening to the questions and answers I have learned a lot. Unfortunately I don’t remember seeing this addressed before, so I have to ask one myself.

It looks like you reduced the maximum time I could delay the code assist window from interrupting me.

I keep the setting set high because I am a slow typist, and I sometimes pause while I’m coding. When I pause too long that window pops up, blocks the part of the screen I’m typing in, prevents me from leaving the line I’m on, and won’t go away until I grab the mouse and click outside it.

Code assist is very useful sometimes, but, the way I type, 99 times out of 100 it is just an interruption. I’d rather be able to set the threshold higher, but if that can’t be done I need some way to turn it off entirely.

Please don’t make me try to go back to SQL Developer. This product is much superior.


#2

I just compared a few semi-recent versions of Toad and it looks like 2 seconds has been the max for some time. What version are you coming from and what version are you now on?

If you seldom use it I recommend disabling its auto invoke behavior. In Toad 13.1 on the Editor|Code Assist page in Options uncheck “Auto invoke.” You can still use Code Insight manually by pressing CTRL+T at any time. This is my preferred mode of operation because I usually find popups I didn’t request to also be a bother.

image


#3

I went to 13.1 right after it was released. I’ll turn off auto invoke and run with that for a while. Thanks.


#4

I don’t see where the max delay has changed. It continues to have a 2 second cap. If you are seeing something else where maybe it’s more aggressive than in the past send it along.