Toad World® Forums

Ctrl+P shortcut in Editor

I assigned Ctrl+P shortcut to Editor|P/SQL style. Toad shows the Windows built-in Print window after I press this shortcut on a non-empty Editor tab. If the tab doesn't contain any character the new Pl/SQL style open is success.

It seem the print function steals the configured shortcut key.

I can reproduce the effect described as well.. Dev team please take note... There could be a three-way conflict that might be affecting Toad's proper recognition of this particular shortcut sequence, since Ctl-P...

  • Activates the Win OS-side Print panel
  • Is assigned by default to the Toad Editor's "Strip Code" capability
  • Can be assigned to another Toad command (such as changing to PL/SQL Style in your example) and so presents a conflict in the same command category (Editor) per the snap below.

Thanks Gary! Of course I unassigned the default Ctrl+P shortcut from Editor|Strip Code Statements. If my memories are good this shortcut setting was okay for the previous 13.3 version.

I should have mentioned that I, too, unassigned the shortcut for the "strip" command (actually re-assigned its shortcut to a non-conflicting keycut) but the problem still persists... Dev or Support will need to take a deeper dive into cause of this conflict.

I can reproduce this and will fix. So, short version is that even if you unassign the File-Print shortcut in the shortcut options, CTRL+P still prints, right?

yes exactly, but this happens only if the current tab of editor contains at least one character.

It should be fixed in the next beta.

1 Like