Toad World® Forums

End-of-compatibility with MS SQL 2008

Hi there, I got License error on 3 computers that were running Toad for SQL Server Freeware 7.0
So, I decided to upgrade to newest 7.1, but I started to get error with some Database Tables (Incorrect parametre Incorrect syntax near '{'. ) when the server machine has Microsoft SQL Server 2008 R2 installed.
In the Server Requirements of the new 7.1 version, there isn't that version of MS SQL Server, so probably, they are not compatible.
I would like to fall back to the Toad 7.0 but after a uninstalling/reinstalling, it continues to ask me the License.

How can I reset this request?
Bye, thanks in advance.
Manuel Vasile
IT Consultant

This should go in the Toad for SQL Server Forum. I'll move it.

1 Like

Hi Pauwe,

Could you send me creation script for some of these tables? I will fix this bug.

Officially Toad 7.1 doesn't support Sql Server 2008, it means that we stop fully testing for this version. I can look for this bug for you and if it will be quick fix (as I can see it just some misspelling in object reading script) I will fix it

Best regards,
Vasiliy

Hi,
this error - if it is "Couldn't find view 'DATABASEBACKUPFILEDS" has already been fixed but 7.1.2 does not contain the fix yet. It will be in the next Toad for SQL Server release.

Hi there and thanks for your answers.
Dan got the point, I have this error "Couldn't find view 'DATABASEBACKUPFILEDS'" when I click on "OK" button to the error (Incorrect parametre Incorrect syntax near '{'. )
Do you already know when the new version will be released?

For Vasily: my problem isn't about a Query, but on the database-connection.

thanks

I am also getting this error with SQL Server 2008. Do we know when this will be fixed? I can't use Toad 7.0 due to license expired.

Hi,

For workaround you can use next:

Open Options and follow next steps:

  1. Select Database\Sql Dictionary
  2. Select Db.CommonSql\ListDatabases
  3. Check that version is 9.0
  4. Go to line 21 and remove selected text(see picture)

  1. Save changes

It will fix the problem

Vasiliy