Toad World® Forums

Error

When I tried to connect to oracle database from Toad for oracle 2015 Direct connection, I got on the below error

Can’t initialized oci Error -1

How can i solve this error?

Thanks

  1. Make sure you have the right bit (32/64) Oracle client installed. It should match Toad.

  2. Sometimes this error will occur if you make a connection in Toad using one Oracle client, then you disconnect and try to make a connection using a different Oracle client. Unfortunately, the DLL’s don’t always unload properly and it can cause errors.

Thanks for your reply

I am using both Toad & oracle client 32 bit

and I uninstall Toad version 9 & installed Toad for oracle 2015

after installation, I tried to connect but the same error

How can i solve this issue

Thanks

From: John Dorlon [mailto:bounce-jdorlon@toadworld.com]

Sent: None

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Error

RE: Error

Reply by John Dorlon

  1. Make sure you have the right bit (32/64) Oracle client installed. It should match Toad.

  2. Sometimes this error will occur if you make a connection in Toad using one Oracle client, then you disconnect and try to make a connection using a different Oracle client. Unfortunately, the DLL’s don’t always unload properly and it can cause errors.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or Unsubscribe from Toad for Oracle - General notifications altogether.

Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.

64 bit Windows likes to install 32 bit programs in a “Program Files (x86)” folder. Having a parenthesis in Toad’s path will cause the older Oracle clients (most versions 10.2 and older) to fail to connect. This is an Oracle bug and it was fixed in version 11. To work around it, re-install Toad to a folder without parenthesis (or get a newer Oracle client!)