Toad World® Forums

Oracle 8 desupported?

I observed that last Toad versions do not work any longer with Oracle 8i databases.

I do know that it is really old, yet there are some of them still alive ( regrettably ... ).

Desupporting 8i version is by design or by chance?

Best regards

Mauro Papandrea

Desupported, officially - yes (a long time ago)
But, we didn't intentionally change anything. So it should still work, and if it's a simple fix, I'll fix it.
Can you be more specific than "does not work"?

For instance, from Schema Browser , Tables, just click on a table:
"ORA-01460: conversione richiesta non implementata o irrazionale
"
Same thing if you click on Data, on the right panel
Same thing for procedures
Thank you
Regards
Mauro

Which Toad versions, specifically? I think this was a problem in 14.2 but it should be fixed in 15.0.

I am using beta 15.1.29.1238 but I ran into this issue in previous versions
Regards
Mauro

Try disabling the Oracle client in beta.

Options -> Oracle -> General. Uncheck "Use Oracle client"

You will only be able to use the "direct" connection method with this option unchecked.

I don't know if that will solve the problem, but it might.

Well, it worked but there is an even weirder thing: if I check "Use oracle client" the direct connection does not work and yet it should be the same in both cases.
And however version 10g client is supposed to work with Oracle 8i
Perhaps I should install an older version of Toad just for those few old 8i still alive
Regards
Mauro

"Direct" is not the same in both cases.

When "Use Oracle Client" is checked, (or Toad 15.0 and prior), "Direct" is a way to connect without having to use TNSNames.ora. But the connection still goes through the Oracle client.

In 15.1, when "Use Oracle Client" is unchecked, Toad connects directly to the database. No Oracle client is used or even needs to be installed.

It may be for the best to keep an older Toad around for Oracle 8i. That's probably more convenient than turning the "Use Oracle client" option on and off.

So with Toad 15.1 no oracle client is really required, very interesting.
This could become really handy with Oracle versions way too far from the installed client.
And as to old versions you are quite right, it is better to have an older Toad than keeping on switching that option on and off
Thank you
Have a nice day
Mauro

I patched my Oracle client, now with 10.2.0.5 Toad works fine even with 8i
I posted this just in case there is someone else still dealing with old Oracle versions
Regards
Mauro

Thanks Mauro. That's interesting. What was your client version before you patched it?

It was plain 10.2.0.1, the basic one.
Regards
Mauro