Toad World® Forums

Db link issue with old 8i version


#1

I know that nowadays using such an old Oracle version is not a great idea ( but perhaps I am not the only one still having to use some old databases ) so I understand if this post of mine will not be considered.

However, using a db link between an old 8i and, for instance, a 10g is something that Toad dislike and makes it go crazy.

This is true in commercial version as well.

If it were possible to fix it would be nice.

Anyway, best regards

Mauro


#2

I just made a DB link on a 10gR2 database that connects to an 8i database.

Then in Toad I ran:

select * from user_tables@orcl817

and didn’t have any errors. Can you be more specific about your problem?


#3

Evening John, Mauro,
I’m wondering if this might be a client problem? The current client/server compatibility matrix - Doc ID 207303.1 - has the details, if you scroll right down the page to the second matrix, with the older versions of Oracle.
Using a DB Link from an 8i database will only be guaranteed to work if the 8i database is remote database is 8.1.7 and the remote 10g database is 10.1 or 10.2. However, those combinations are not supported now.
Any 8i version prior to 8.1.7 has “never” worked.
Bear in mind also that the client version on the Windows Box where Toad is running is only responsible for the Toad connection, any work done over the DB link is done using the client software of the database with the DB link created within.
Looking at the compatibility matrix, 8.1.7 used to be supported and able to connect to 10.2 down to 7.3.4 only. Nothing higher than 10.2 is supposed to work.
On the other way around, a 10g database with a DB link to an 8i database will get an ORA-3134 error if the 8i database is 8.1.6 or lower.
HTH
Cheers,
Norm. [TeamT]


#4

I am sorry I was not clear enough, actually the issue is when the database link is from 8i to 10g.

In my case I start from 8.1.7, so it is not a problem of compatibility and, as a matter of fact, the very same db link works fine in sqlplus ( and in other tools as well ).

Instead, in Toad its first use returns ora-03113 error and after that nothing works: every sql statement returns an undefined error ( the usual error window that Toad returns for errors is empty and that can make sense since no real Oracle error exists ).

The only way to get out of this is a reconnection.

Best regards

Mauro


#5

Using the same version of Toad, I could make it work when I ran Toad on the machine with the 8.1.7 database. could reproduce the error on a different machine (with a 9.2 client)

I think it has something to do with the fact that Toad uses the Unicode-enabled OCI calls, because when I try it with Toad 9.7, I can’t reproduce the error.

I think if you can use the 8.1.7 client, you won’t have a problem.


#6

I shall try to install an 8i client and I shall let you know if it works.

However, with 10g client, the issue does not reproduce from a 9.2 ( or later ) to 10g, only from 8.1.7

Regards

Mauro


#7

It was hard to installa a 8i client after a 10g …

However, now I have a 8i client as well.

I am sure it works because sqlplus 8.1.7 ia able to connect but Toad returns a weird error when I try to use 8i client.

First, I complained about TNS_ADMIN missing, I added it and it still returns an error.

The tnsping button in the top left corner works fine.

The error text is unreadable ( all small squares ); below that some information about the client.

Using the link at the bottom I could see the real Toad error and it is :

“No valid Oracle Clients found” error message when launching / starting Toad. (71545)

What am I missing?

Regards

Mauro


#8

It’s hard to say. when my Oracle clients get in a state like that, I remove them all, make sure that HKLM\SOFTWARE\ORACLE is completely gone from the registry, that it’s gone from my path too, and I reinstall the Oracle clients from oldest to newest. That has always worked for me. Sorry for the headache.


#9

I cleared averything ( even my registry ) and reinstalled 8i client.

Same error.

Well, lucky me this is not vital … :slight_smile:

Regards

Mauro