Toad World® Forums

Toad connections screen slow to open and need to click X twice to close the toad program

Hi

Downloaded latest (5.8.2020) toad for oracle 64 bit, version 13.3.0.181

Noticed that I need to click X (Close window) from the upper right corner twice for toad window to close.

I tested it a bit, and seems like when I have 1 or more database connections open, then with first click it will close all present database connections. And then the second click closes toad program itself.

But yeah, when I only have toad program opened up (without any connections present) - why I need to click X twice..?

I mean, if this is a feature, that first click closes all connections and second click closes program itself. Then without any connections present, I should not need to click X twice, don't you agree..?

(This behaviour seems to be same for the 13.1.1.5 version)

Secondly, when I open new toad program (13.3.0.181), then after the toad window has opened, then it takes ages (10+ seconds) to load my connections screen.
For example, I have version 13.1.1.5 on the same server, and when I open this version of toad, the connections will be loaded momentarily.

Connections were copied from 13.1 user's files to 13.3 users files automatically (I did not manually copy these)
So there should be same connections present for both version of toad.

Raul

Toad shouldn't take 2 clicks on the X to close it. You might get some prompts about saving editor contents, etc, but after that it should close. I'm not sure what's going on there.

How many connections do you have in your login window? For me, the login window in 13.3 opens instantly.

If you zip up and send me your user files folder, I'll take a look. You can send it to john.dorlon@quest.com. Click here for directions on how to find the correct folder to send.

No prompts, I haven't got anything open (no connections, no editors no nothing).

But I think I have figured it out.

Our toad is installed in company intranet, so we can't connect to internet at all.
At first I had this file called online_resources.xml in toad user files.
But still looks like it tried to connect somewhere.

So then I added InternetAccess=0 to Toad.ini file and removed online_resources.xml file at all.

And both problems were gone in my case.

Raul

1 Like

Isn't there a such way, that when I install new version of toad, then all the users have this automatically set to 0..?

InternetAccess=0

Or only way is set this to 0 manually after toad upgrade..?

Raul

Hi Raul,

The easiest way to handle that situation is by running Toad's MSI installer with the parameter "RESTRICTIONS=i". You can find out more about that installation option here:

https://support.quest.com/technical-documents/toad-for-oracle/13.3/installation-guide/3#TOPIC-1384494

Feel free to give that a shot and let us know if you run into any other issues.

-John

Hmm, what would be the full statement then..?

Where do I put "RESTRICTIONS=i" ?

msiexec /i "\\path_to_installer\ToadforOracle_GA_13.3.0.181_x64.msi"

Just like that:

msiexec /i "\\path_to_installer\ToadforOracle_GA_13.3.0.181_x64.msi" "RESTRICTIONS=i"

Also where this restriction (no internet access) is added..?
(is it added to users folder Toad.ini file? )

Raul

Hi Raul,

You don't need to enclose it in quotes. You should be able to simply use:

msiexec /i "\path_to_installer\ToadforOracle_GA_13.3.0.181_x64.msi" RESTRICTIONS=i

This will add a registry setting in HKLM\Software\Quest Software\Toad for Oracle to restrict users' internet access on the machine.

-John

Thanks. It works yeah.

Secondly. I would like to know, if Toad for Oracle is used within Windows Server 2019
Must there be made some special configuration, since users's are complaining that Toad is getting quite slow to operate (switching tabs, tables (in schema browser, etc..))

If I install it in localhost (my own computer), then there is quite the difference.

Raul

I've never heard of any reports of slowness from Windows Server 2019. If you turn on spool SQL, do you get any clues there? Or do you think it is something else? You might want to try resetting user files to a clean install. Steps to do that are here (no need to reinstall Oracle client for your case)

If this is a VM, make sure it has enough CPU and memory. I don't know what "enough" means exactly, but you can try increasing it.