TOAD not shutting down completely/successfully

I'm not able to reproduce this on command, but in two cases now (17.0.216) TOAD hasn't shut down completely (Windows 10). One or more of the connections will close, but the shutdown will just stop. Any subsequent attempts to shut down TOAD (using the X in the upper-right corner), just result in the dialog asking to shut down, but nothing else happens. Also, Windows no longer registers TOAD as a running application, so can't even use Task Manager to do a hard shutdown. I've had to just reboot the pc each time this has happened.

Hm, I haven't heard of this one before.

The only thing that "should" block a shutdown is if you cancel it (either by cancelling out of the shutdown confirmation itself or some window like prompting you you to save a file and you hit Cancel)

are any windows in Toad still open? if so, which one(s)?

Next time it happens, maybe Main Menu -> File -> Fast Exit will work better

or maybe kill from command line? TaskKill: Kill process from command line (CMD) I'm guessing that one wouldn't work if task manager doesn't, but it's worth a try.


Thanks for the quick reply.

No windows open, other than the main TOAD window, with anywhere from 3-10 connections. I definitely didn't cancel the shutdown. The last time, I was off doing something else and came back expecting TOAD to be shut down, but it still had several open connections, with no dialogs about rollback or save or the like, which will pause the shutdown until acknowledged.

The weird thing is that the X is still active when it's in this state, and it asks if I want to shut down like normal too. It just doesn't do anything after that.

I don't see a "Fast Exit" option in the file menu, just Exit, which seems to do the same thing as the X does.

I'd rather not have to go the command line option route if at all possible.

The "Fast Exist" was added for 16.2 or so. You may have to "customize it in"

  • Right-click toobar -> Customize toolbars
  • go to the "command" tab
  • "File" is already selected on the left
  • Find "Fast Exist" on the right (about 1/2 way down)
  • drag it into the main menu
  • Close the customize dialog.

The idea with that feature is that it doesn't give any "save" or "commit" prompts. it gives one "are you sure" prompt, saves your workspace (if configured) and then just shuts everything down as quickly as possible.

I'd rather not have to go the command line option route if at all possible.

I don't blame you. Just trying to offer an alternative to restarting your PC until we figure out what's happening.

Ah, so the connection buttons are still on the toolbar?

I wonder if one of them has timed out and there was some error behind the scenes that messed things up. I'll try that here.

Yes, it will shut down some of them, but leaves some of them open.

I did notice that version 17 is no longer complaining when a connection isn't active when I shut TOAD down, which was super-annoying in prior versions. So I was glad to see that. But maybe that's where the problem is. Hopefully you can find something. Unfortunately it hasn't happened every time. I'm usually running 2-4 copies of TOAD at once, due to past experience of TOAD getting really unstable at or above 10 connections. So, I've had many instances close down just fine since I've been running 17 for a week or so. I say unfortunately because bugs are harder to track down when they are transient and/or unreproducible.

Also, I am now running in client-less mode, which I never did in 16.3 and prior. Not sure if that helps any. Is that why it doesn't nag me when a connection isn't active when I shut TOAD down?

Ok, got it. I have added it now. I'll try it later today.

That 'Oracle has ended the session or the connection is dropped!' message is a no-nag, so I guess you checked "don't show this again" at some point.

I have also checked "don't show this again". I tested with no-client mode still not sure what's happening here.

Multiple copies of Toad running could be a problem. Do you use the /VIRTUAL command line option when you start a 2nd, 3rd, etc? This will make those copies of Toad create their own copy of settings, and eliminate the possibility of "file in use" clashes. Not sure if that's related to what's going on, but it's a safer way to go.

actually, I'm going to correct myself here on that "Oracle has ended the session..." message.

Looks like we haven't shown it on shutdown for several versions. It only shows (unless you disable it) when ending connection and NOT shutting down Toad.

Well, just tried fast exit for the first time, and it didn't work. The TOAD instance still looks like it did (no connections closed at all), but Windows has no knowledge of it anymore and i can't click anything on it this time. Alt-tab shows no error boxes or TOAD sessions.

I've been trying to reproduce it here with various scenarios but so far nothing has worked.

This doesn't seem like it would be options related, but I'll be happy to try again if you zip up and send me your user files folder

  1. Go to Main Menu -> View -> Toad Options.
  2. Along the left side, click Files and Folders -> App Folders
  3. On the right, in the "Application data directory" box, click the "Open Folder" button. A Windows Explorer window will open.
  4. Close Toad before you continue.
  5. In Explorer, Zip up the "User Files" folder.
  6. email it to me:

Another thought - when it happens - can you end connections first, then close Toad? (Edit: Hm I see in your last message that you can't click on it anymore)

Do you think it may have started in Toad Beta 17.0.204, Released 21-Aug?

I made a change that might fix it. It will be in next beta (Tuesday this time since Monday is a holiday in the US).

Still not working in 231. I suspect it's something in one of the connections in one of my workspaces. Other workspaces close down fine. It behaves slightly differently now, where the Windows blue swirling donut shows now, but I can still click on things, including the red x, but it won't shut down unless I kill it. But now it DOES still show in task manager, so I can kill it there. That always makes me nervous though, as I have lost all my settings many times due to TOAD crashing or being killed.

Hi Chris,

Thanks for the update. Well, that's an improvement at least.

If you close those connections manually, do they close OK, or is the problem only when trying to shut Toad down completely?

Do you have color themes enabled? If so, will you try it with them disabled and let me know if that makes any difference?

FYI, Starting in Toad 16.3 there is an auto-backup system of user files folder. There is a folder right next to it called "User Files Backups". It doesn't include everything in user files by default but it does include workspace and other important files. By default the backup is taken about 1 minute after Toad starts, once per day. So if you start/stop Toad multiple times per day, it only backs up the first time you start it each day.

Oh, also - if a connection has timed out and Toad starts hanging, I have noticed that I can click the red "X" a 2nd time, then "try to restore the program" and it becomes responsive again. Details on this post. Let me know if that helps.

And one more thing - Try turning on freeze detection and posting the log here. That may give us some good info.


So I've narrowed it down to the misbehaving connection. It appears to be something to do with that connection's editor. I can't even close any of the tabs in the editor (only 2). One tab is a package body and the other is just a normal tab. I can create a new tab, but then the other two tabs look blank. I can click on them, but the contents don't change from the blank screen from the new tab.
Also, when I load this workspace, about a minute or so after loading it, I always get this popup:

Here are the details of that:

Toad.el (1.5 MB)

Oh, that's an error in our backup engine that I've been trying to track down!

Can you send zip up and send your user files folder (and let me know which workspace this is)? My email address is

After you zip up your user files folder...if you go to Options -> Editor -> Behavior and uncheck "backup editor every ____" minutes, this will stop. This is not a long-term solution of course. Hopefully we can reproduce this and fix it.

I sent you the files.

1 Like