Toad World® Forums

After closing Toad program, it becomes unresponsive in environments where no public internet access is allowed

Hi

Toad 14.1.120.923

Another thing I noticed that seems to be due to no public internet access on server where Toad is installed..

When closing Toad with the X (on top of right corner), seems like it is doing another web check there also or sth.

Toad is also installed using " RESTRICTIONS=i ", which should disable internetaccess:

PS> msiexec /i "..../toad/ToadforOracle_GA_14.1.120.923_x64_En.msi" /q RESTRICTIONS=i

Toad.ini setting does not work also:

[SETTINGS]
InternetAccess=0

When Toad is installed into the PC where I have public internet access, there is no such problem.

Regards
Raul

Raul, try making this setting too.

Hmm, I don't see how, there is no such option there. Perhaps this is present only if I have installed with internet access..?

image

Raul

Hm, Maybe so.

Look for this in Toad.ini: FeedBackOptIn=

If you find FeedBackOptIn=1, change it to FeedBackOptIn=0

You can also add FeedBackOptIn=0 (under SETTINGS) if it is not found at all.

I checked Toad.ini file and it was enabled indeed.

[SETTINGS]
...
FeedBackOptIn=1

I changed it to 0 and saved this file.

Opened toad and then closed it, and now it indeed closed within 1-2 second.

So I think this setting must depend on internetacces, if I install Toad with internetaccess disabled (via Toad.ini or registry entry), then this FeedBackOptIn setting should default to 0 also.

Regards
Raul

1 Like

Does that also help your start up time?

Unfortunately no, it did not change anything there.

Raul