Toad World® Forums

Toad Oracle Base Edition 12.11.0.95 compare not finding mismatches or missing objects

Doing a database schema compare between two systems and no differences are found even though differences exist. There is no filter being used. Has this feature been turned off for the base edition? The last version the compare worked though you were only able to view the sync script.

I ran a compare with 12.10.0.30 and it worked find …

This feature hasn't been turned off for the base edition and it behaves the same as previous releases. What object types do you believe there to be differences with? There's a bug with package bodies not being displayed. The older schema compare can be enabled by clicking on the below image and following the steps as well to verify that Toad is finding the differences.

Well, it didn’t find missing tables, indexes, sequences synonyms, triggers, pk constraints, foreign key constrains…

It’s the direct connecct that causes the problem in 12.11. It’s fixed for 12.12.

You can work around it by typing all that stuff in uppercase in the login window, or making a TNSNames entry for it.

thanks. I’ll get the latest edition