Toad World® Forums

Upon opening a file with the Editor, Special Characters are removed,


#1

Tod for Oracle version 13.
I have a file (a.sql) that contains a line like:

do_something (’// FIELD 198 to 207eTOTAL Dollar$’);

That e is basically char(27).
In an editor like Notepad++ the line looks like:

pkg_fputline (’// FIELD 158 167ESC08QTY4’);

Upon opening the file in Toad ( File /Open File), the symbol e is removed.
How can this be avoided?
Thanks.


#2

Save it as unicode?

That’s what i would try.


#3

Thanks.
Well the issue is not saving it. Is just opening it.
The file is saved fine in Notepad++ or Sql Developer for example.
But in Toad as soon as you open it, the character disappears.


#4

I didn’t mean saving in Toad, I meant saving in wherever the file was created. So it’s already unicode when Toad opens it.


#5

Yeah that doesn’t work. The files are saved in Unicode


#6

Toad specifically removes all unprintable characters. Unfortunately I did not place a good comment at this change or tie it to an issue logged in our tracking system. :frowning: I’ll remove that change and whatever concern there was by allowing unprintables will re-surface in time. :slight_smile:


#7

Ok. Was hoping for an Option to allow them. But is ok.
Thanks from promptly answer/