Toad World® Forums

Warning Toad Message

I’m update to the latest Version of Toad for Oracle (12.1.0.22). Now I want to save a SQL-File and the following message appears:

Toad Message

Error connectiong to the repository. The repository may be temporarily unavailable. Please try again shortyl.
Reason: Trying to create a TNamespace on a non existant File object.

What’s that? I’m only want to save the SQL to my local harddrive.

With Kind regards,

Patrick

Hello Patrick,

This issue was discovered yesterday. The workaround is to go to
the “CommonDialogFavorites” item in your Toad.ini file and remove any invalid directories that are listed. You can find your Toad.ini file by going to options > general,
and clicking “Open folder” under your application data directory.

Thanks,

Brad

From: patrick.hartzsch [mailto:bounce-patrickhartzsch@toadworld.com]

Sent: Tuesday, October 01, 2013 3:47 AM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] Warning Toad Message

Warning Toad Message

Thread created by patrick.hartzsch

I’m update to the latest Version of Toad for Oracle (12.1.0.22). Now I want to save a SQL-File and the following message appears:

Toad Message

Error connectiong to the repository. The repository may be temporarily unavailable. Please try again shortyl.

Reason: Trying to create a TNamespace on a non existant File object.

What’s that? I’m only want to save the SQL to my local harddrive.

With Kind regards,

Patrick

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

We have just been upgraded to version 12.1.0.22, and I’m experiencing the same issue that Patrick reported. I ran the Copy User Settings utility and got back all of my saved settings, but the location of my saved SQLs didn’t come over. I edited my TOAD.INI file and added the directory that contains my saved SQL files. Closed, reopened, checked that the change was there, but still getting the same error when I click Open File or Save File As. Can anyone help me?

There’s nothing to add to Toad.ini to specify the location. Copy SavedSQL.dat from your previous Toad’s user files folder to your new Toad’s user files folder. See if that does it.

On 02/06/2015 01:57 PM, pwhite1048 wrote:

RE: Warning Toad Message

Reply by pwhite1048
We have just been upgraded to version 12.1.0.22, and I’m experiencing the same issue that Patrick reported. I ran the Copy User Settings utility and got back all of my saved settings, but the location of my saved SQLs didn’t come over. I edited my TOAD.INI
file and added the directory that contains my saved SQL files. Closed, reopened, checked that the change was there, but still getting the same error when I click Open File or Save File As. Can anyone help me?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

That did not fix it. We went from version 11.5 to 12.1.0.22. The error message is “Error connecting to the repository. The repository may be temporarily unavailable. Please try again shortly. Reason: Trying to create a TNamespace on a non existant File object.” Toad 11.5 didn’t have a ‘repository’ that I am aware of, it let you point to a folder and that was that. Is there some conversion from folder-based to repository-based that we need to run? Any way I can manually “create a TNamespace”?

Go to options > online and set “script repository” to disabled. This should fix it

Oh wait, you’re on 12.1. Sorry, this option was introduced in 12.5.

From: Brad Boddicker [mailto:bounce-ButtonPusher@toadworld.com]

Sent: Friday, February 06, 2015 2:58 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Warning Toad Message

RE: Warning Toad Message

Reply by Brad Boddicker

Go to options > online and set “script repository” to disabled. This should fix it

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

There are two features in the mix within this thread. SavedSQL.dat file is the file used by SQL Recall. It’s unrelated to the repository and error message reported by the OP.

What exactly is your issue? Your prior posts suggests you’re looking for your SQL Recall statements from the prior release. Now you’re getting the repository message, correct? Are you experiencing both issues or just this repository one?

Thanks,

Michael

On 02/06/2015 02:53 PM, pwhite1048 wrote:

RE: Warning Toad Message

Reply by pwhite1048
That did not fix it. We went from version 11.5 to 12.1.0.22. The error message is “Error connecting to the repository. The repository may be temporarily unavailable. Please try again shortly. Reason: Trying to create a TNamespace on a non existant File
object.” Toad 11.5 didn’t have a ‘repository’ that I am aware of, it let you point to a folder and that was that. Is there some conversion from folder-based to repository-based that we need to run? Any way I can manually “create a TNamespace”?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Try applying the Toad 12.1.1 patch. There was an issue in Toad 12.1.0.22 in which an “Error connecting to repository” error could sometimes appear. Upgrading to Toad 12.1.1 may fix your problem.

I’m getting the message that the OP got. I’m getting it when I select File --> Open. Also when I select File --> Save As. I have looked at Options > Online where I can create a private script repository, but it seems that’s attached to the database I’m connected to, which (even if I had permission) seems to mean I would have to have a repository in each of the six databases I query from. As the OP said, I just want to save my SQL files to my local hard drive.

John, our environment is controlled and I can’t just download software or apply a patch. Toad 12.1.0.22 just became available to us this week. Every software change has to be checked, vetted, approved, etc. etc. at the highest levels of the org before we can have it. (We’re still on IE8 if that gives you a picture of our situation.)

I assume you tried this…

The workaround is to go to the “CommonDialogFavorites” item in your Toad.ini file and remove any
invalid directories that are listed. You can find your Toad.ini file by going to options > general, and clicking “Open folder” under your application data directory.

As a last resort, resetting your user files should fix it, but you will lose all of your preferences and previous SQL, etc (Utilities > copy
user settings).

From: pwhite1048 [mailto:bounce-pwhite1048@toadworld.com]

Sent: Friday, February 06, 2015 3:28 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Warning Toad Message

RE: Warning Toad Message

Reply by pwhite1048

John, our environment is controlled and I can’t just download software or apply a patch. Toad 12.1.0.22 just became available to us this week. Every software change has to be checked, vetted,
approved, etc. etc. at the highest levels of the org before we can have it. (We’re still on IE8 if that gives you a picture of our situation.)

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

This is terrible advice. How did you get to become a Technician?

From: Brad Boddicker [mailto:bounce-ButtonPusher@toadworld.com]

Sent: Friday, February 06, 2015 3:36 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Warning Toad Message

RE: Warning Toad Message

Reply by Brad Boddicker

I assume you tried this…

The workaround is to go to the “CommonDialogFavorites” item in your Toad.ini file and remove any
invalid directories that are listed. You can find your Toad.ini file by going to options > general, and clicking “Open folder” under your application data directory.

As a last resort, resetting your user files should fix it, but you will lose all of your preferences and previous SQL, etc (Utilities > copy
user settings).

From: pwhite1048 [mailto:bounce-pwhite1048@toadworld.com]

Sent: Friday, February 06, 2015 3:28 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Warning Toad Message

RE: Warning Toad Message

Reply by pwhite1048

John, our environment is controlled and I can’t just download software or apply a patch. Toad 12.1.0.22 just became available to us this week. Every software change has to be checked, vetted,
approved, etc. etc. at the highest levels of the org before we can have it. (We’re still on IE8 if that gives you a picture of our situation.)

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Do you have any better suggestions? Go back into hibernation

From: Mark Lerch [mailto:bounce-Mark_Lerch@toadworld.com]

Sent: Friday, February 06, 2015 3:52 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Warning Toad Message

RE: Warning Toad Message

Reply by Mark Lerch

This is terrible advice. How did you get to become a Technician?

From: Brad Boddicker [mailto:bounce-ButtonPusher@toadworld.com]

Sent: Friday, February 06, 2015 3:36 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Warning Toad Message

RE: Warning Toad Message

Reply by Brad Boddicker

I assume you tried this…

The workaround is to go to the “CommonDialogFavorites” item in your Toad.ini file and remove any
invalid directories that are listed. You can find your Toad.ini file by going to options > general, and clicking “Open folder” under your application data directory.

As a last resort, resetting your user files should fix it, but you will lose all of your preferences and previous SQL, etc (Utilities > copy
user settings).

From: pwhite1048 [mailto:bounce-pwhite1048@toadworld.com]

Sent: Friday, February 06, 2015 3:28 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Warning Toad Message

RE: Warning Toad Message

Reply by pwhite1048

John, our environment is controlled and I can’t just download software or apply a patch. Toad 12.1.0.22 just became available to us this week. Every software change has to be checked, vetted,
approved, etc. etc. at the highest levels of the org before we can have it. (We’re still on IE8 if that gives you a picture of our situation.)

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

yes, I checked the CommonDialogFavorites. I see a user with the same issue in the “12.1 and repository” thread: “Chris Johnson / 20 Sep 2013 at 2:48pm – I just upgraded to 12.1.0.22 and now when I try to open a script it get an error about not being able to access the repository. I have never set up either a public or private repository. Now I can’t open any scripts. how do I disable this?”

This is exactly my problem. When I try to open a script I get an error about not being able to access the repository. I have never set up either a public or private repository. Now I can’t open any scripts.

How do I get to my saved scripts that are on my hard drive? How do I save new scripts to my hard drive? I don’t have a Toad repository, I don’t know what is contained in a Toad repository, I don’t know how a Toad repository works, and from the reading I’ve been doing about Toad repositories this afternoon, I suspect that I am going to have to go back to Toad 11.5, and my entire team will have to stay with that version.

Did you have any CommonDialogFavorites listed? If so, did you try to remove them?

Like I said below, if you can’t apply a patch, the only other alternative I have for you would be to go to utilities > copy user settings and select “Create
clean set of user files from base installation”

This basically resets your user files. Now, if you really need certain things, like saved SQL, you can go back to your previous user files and manually copy
that file over to your new user files. Also, if for any reason you need to restore your user files, Toad renames the folder to 12.1_bak.

From: pwhite1048 [mailto:bounce-pwhite1048@toadworld.com]

Sent: Friday, February 06, 2015 3:58 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Warning Toad Message

RE: Warning Toad Message

Reply by pwhite1048

yes, I checked the CommonDialogFavorites. I see a user with the same issue in the “12.1 and repository” thread: “Chris Johnson / 20 Sep 2013 at 2:48pm – I just upgraded to 12.1.0.22 and now
when I try to open a script it get an error about not being able to access the repository. I have never set up either a public or private repository. Now I can’t open any scripts. how do I disable this?”

This is exactly my problem. ** When I try to open a script I get an error about not being able to access the repository. I have never set
up either a public or private repository. Now I can’t open any scripts.**

How do I get to my saved scripts that are on my hard drive? How do I save new scripts to my hard drive? I don’t have a Toad repository, I don’t know what is contained in a Toad repository,
I don’t know how a Toad repository works, and from the reading I’ve been doing about Toad repositories this afternoon, I suspect that I am going to have to go back to Toad 11.5, and my entire team will have to stay with that version.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Until you get it sorted out you can drag files from Explorer into Toad or make use of Toad’s Project Manager.

Is a repository part of your user files? If it’s not, then resetting my user files is not going to help me.

As Brad mentioned (he beat me the response), if you have any entries listed in the CommonDialogFavorites and/or CommonDialogFavoriteNames items within your Toad.ini file, I’d first suggest removing those entries.

The reason we’re steering you towards this option first is because there was an issue in Toad 12.1.0.22 in which an invalid local path in one of these INI items caused the exact error you’re seeing. Even if it looks correct, we’ve noticed issues where the Windows API calls behaved strangely causing this issue. If you remove all entries for those keys, there will be no local favorites to load into the Favorites tree, which could potentially solve your problem.

The repository was an option we included to be able to share files with other TOAD for Oracle users through a centralized cloud-based library. The error you were seeing occurred during the initialization process of the repository and local sides of the dialog box. Even though it had nothing to do with the repository itself, the dialog was showing the incorrect error. This issue was fixed with the 12.1.1 patch, but this was the workaround we suggested for existing users until the patch was released.

If that fails, Brad’s suggestion for resetting your user files should also work as well.

OK, I can drag a query into Toad from Explorer. That’s a baby step in the right direction…at least I can execute my queries. But I still cannot Save or Save As because of the repository issue. I did find the 5 minute video about repository for Toad 12, but it only served to depress me more. I don’t need or want a repository, and neither does anyone else on my team. This is a giant leap backwards and unless someone has a solution I can use with the current version of the software, I’m going to have to go back to 11.5.